首页>

请问易语言怎么用第一个程序去控制另外一个程序?

时间:2020-08-12 00:33:49 /人气:751 ℃
请问易语言怎么用第一个程序去控制另外一个程序?
以下是2113代码首先用窗口标题取被改变标题5261窗口的句柄,然后4102通过dll命令改变标题。
(被改变窗口标题是1653“要改变的标题”)
.版本 2
.程序集 窗口程序集1
.程序集变量 句柄, 整数型
.子程序 __启动窗口_创建完毕
.子程序 窗口_置标题, 逻辑型, 公开, 改指定窗口句柄的窗口标题(非"0"表示成功,返回"0"表示失败)
.参数 窗口句柄, 整数型, , 欲更改窗口标题的句柄
.参数 新标题, 文本型, , 欲改成的新标题
返回 (SetWindowTextA (窗口句柄, 新标题))
.子程序 取句柄, 整数型, 公开, 成功返回控件的句柄,失败返回0
.参数 父窗口句柄, 整数型, 可空, 如果是取顶级的窗口句柄请留空
.参数 子窗口句柄, 整数型, 可空, 如果是取顶级的窗口句柄请留空
.参数 窗口类名, 文本型, 可空, 窗口的类名
.参数 窗口标题, 文本型, 可空, 窗口的标题
返回 (FindWindowExA_文本 (父窗口句柄, 子窗口句柄, 窗口类名, 窗口标题))
.子程序 _按钮1_被单击
句柄 = 取句柄 (, , , “要改变的标题”)
窗口_置标题 (句柄, “你好!”)
.版本 2
.DLL命令 FindWindowExA_文本, 整数型, "user32", "FindWindowExA", 公开
.参数 父窗口句柄, 整数型
.参数 子窗口, 整数型
.参数 类名, 文本型
.参数 标题, 文本型
.DLL命令 SetWindowTextA, 逻辑型, "user32", "SetWindowTextA", 公开, 窗口_置标题
.参数 hwnd, 整数型
.参数 窗口标题, 文本型本回答由提问者推荐

请看例程并采纳谢谢

追问

我说的是控制别的程序,不是别的窗口 -_-#

追答:

见楼上回答



淘金娱乐老平台_皇宝娱乐压大小_牡丹问答学习平台|网站地图